Tous les avis / BE-2022-0013

BE-2022-0013

BE-2022-0013: IFC File Parsing Out-of-bounds Read Vulnerabilities in MicroStation and MicroStation-based applications

ID Bentley : BE-2022-0013
ID CVE : CVE-2022-35904
Gravité : 3,3
CVSS v3.1 : AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Date de publication : 13-07-2022
Date de révision : 13-07-2022

Résumé
MicroStation et les applications basées sur MicroStation peuvent être affectées par des vulnérabilités de lecture hors limites lors de l’ouverture de fichiers IFC conçus de façon malveillante. L’exploitation de ces vulnérabilités pourrait entraîner la divulgation d'informations.

Détails
L’utilisation d’une version affectée de MicroStation ou d’une application basée sur MicroStation pour ouvrir un fichier IFC contenant des données conçues de façon malveillante peut forcer une lecture hors limites. L’exploitation de ces vulnérabilités dans le cadre de l'analyse de fichiers IFC pourrait permettre à un attaquant de lire des informations dans le contexte du processus en cours.

Affected Versions

Applications Affected Versions Mitigated Versions
MicroStation 10.16.* and prior versions 10.17.0.* and more recent
Bentley View 10.16.* and prior versions 10.17.0.* and more recent

 

Mesures d’atténuation recommandées
Bentley recommande d’effectuer la mise à jour vers les dernières versions de MicroStation et des applications basées sur MicroStation. En règle générale, il est également recommandé de n’ouvrir que les fichiers IFC provenant de sources fiables.

Remerciements
Merci à xina1i d’avoir découvert ces vulnérabilités.

Revision History

Date Description
13-07-2022 Première version de l’avis
18-07-2022 Adding CVE number